Loading...
Joomla

Installing Joomla 3.0 Beta 1 – First Trial – Parse Error

I decided to test out Joomla 3.0 Beta 1 and see what New Features there are.  I downloaded the zip file from Joomla.org and uploaded it to my dreamhost web hosting provider.  After unzipping the file in the root of my web hosting, I went to my installation link.  The first thing I got was this error message:

Parse error: syntax error, unexpected T_CONST in /home/cmsmind/cmsmind.com/installation/index.php on line 17

Parse error: syntax error, unexpected T_CONST in /home/cmsmind/cmsmind.com/installation/index.php on line 10

See screenshot below:

Parse Error when installing Joomla 3.0 beta
Parse Error when installing Joomla 3.0 beta

I spent a good 30 minutes trying to resolve this issue and almost tempted to do the Joomla 3.0 beta 1 installation manually but decided against it.  I did some research and finally found the solution to this problem.  The fix was to change my PHP version.  You will have to do this in your web hosting control panel.  Since mine is Dreamhost, I will show you how to do this using Dreamhost.  If you are using another web hosting provider, email them and ask them if they are using PHP v 5.3.x or higher.  Joomla 3.0 beta 1 installation will only work with this version or higher.

Steps to fix in Dreamhost:

1.  Manage Domains in Dreamhost

Go to Manage Domains in your Dreamhost account.

  • Login to your Dreamhost web hosting account
  • Under Toolbox, click on ‘Manage Domains’
Manage Domains in Dreamhost - change PHP version
Manage Domains in Dreamhost – change PHP version

2.  Edit the Domain name

Under all hosted domains on this account, the 3rd column is ‘Web hosting’.  You will see an ‘Edit’ link there.

  • Click on ‘Edit’
Fix the PHP Version for Joomla 3.0 - Edit domain name
Fix the PHP Version for Joomla 3.0 – Edit domain name

3.  Change the PHP version to PHP 5.3.x CGI

Joomla 3.0 beta 1 needs PHP version 5.3.x or higher, so choose that as your PHP mode.  (I previously had PHP 5.2.x).  Under Web Options:

  • Under Web Options
  • Set PHP Mode: = PHP 5.3.x CGI
  • Click on ‘Save Changes’
Change PHP Version to 5.3.x to fix parse error in Joomla 3.0 installation
Change PHP Version to 5.3.x to fix parse error in Joomla 3.0 installation

The changes will take about 5-10 minutes to take affect.  After that you can visit the installation page again and you will see the Joomla 3.0 Beta Installation window.  See screenshot below:

Joomla 3.0 beta installation screen - no parse errors
Joomla 3.0 beta installation screen – no parse errors

Thanks,

Elaine

2 comments
Leave a Reply

Your email address will not be published. Required fields are marked *

Captcha Captcha Reload